Spiceinit issues (Instrument=Null)

I have been recently experiencing issues with the spiceinit ISIS routine when trying to attach kernels to cubes. Specifically I am talking about MRO CTX cubes. It seems that, after creating cubes with mroctx2isis the spiceinit (both with web=true and with kernels on local machine) returns a record in which Instrument = Null

here below is an example related to a CTX image:

Group = Kernels
NaifFrameCode = -74021
LeapSecond = $base/kernels/lsk/naif0012.tls
TargetAttitudeShape = $base/kernels/pck/pck00009.tpc
TargetPosition = ($base/kernels/spk/de430.bsp,
$base/kernels/spk/mar097.bsp)
InstrumentPointing = ($mro/kernels/ck/mro_sc_psp_070710_070716.bc,
$mro/kernels/fk/mro_v15.tf)
Instrument = Null
SpacecraftClock = $mro/kernels/sclk/MRO_SCLKSCET.00083.65536.tsc
InstrumentPosition = $mro/kernels/spk/mro_psp4_ssd_mro110c.bsp
InstrumentAddendum = $mro/kernels/iak/mroctxAddendum005.ti
ShapeModel = $base/dems/molaMarsPlanetaryRadius0005.cub
InstrumentPositionQuality = Reconstructed
InstrumentPointingQuality = Reconstructed
CameraVersion = 1
End_Group

This creates subsequent problems, for example when trying stereo with ASP. It seems a common issue that has also a specific thread here

I tried both conda-based ISIS as well as legacy installations with ASP versions from 2.5.2 to 2.6.2.
I get always the same Null field. Any clues of what is happening or workarounds?

Thanks!

Hi,

Not having an instrument kernel is to be expected. All of the camera parameters that the ISIS CTX sensor models needs are contained in the IAK.

Is it possible for you to provide the full label from your image?

edit - you may want to post your issue over on the ASC discourse https://astrodiscuss.usgs.gov/. More of the ISIS devs watch that.